Installing the old but legendary UT2003 (Physical Copy) on current linux systems!

Ok, so for anyone who has done this in the past when it worked with no problems, should remember how it was possible to install. The third CD of the physical UT2003 disk had a linux_installer.sh file. All you had to do was copy that file to your computer, “chmod +x linux_installer.sh“, then just run it like so “./linux_installer.sh“.

Well now days the installer will give you a few errors when trying to execute it.

1.) The first of course after copying the file from Disk 3 to your computer, is to make it excutable. so open a terminal and navigate to where you copied the linux_installer.sh file, then do the following.

chmod +x linux_installer.sh

Now if you were to just run it like so “./linux_installer.sh“, you will most likely get a error output like i am getting.

Copying to a temporary location…
Verifying archive integrity…tail: cannot open ‘+266’ for reading: No such file or directory
Error in checksums: 3981352260 is different from 3043856338

You need to export posix2 version to something else. So in your terminal do the following.

export _POSIX2_VERSION=199209

Then if you run it again, depending if you are on a 64bit version or a 32bit version, it may either load up or not. I am running Arch Linux 64bit, so i got the following error.

Copying to a temporary location…
Verifying archive integrity… All good.
Uncompressing Unreal Tournament 2003 for GNU/Linux 2107…………………………………………………………….
This installation doesn’t support glibc-2.1 on Linux / x86_64
(tried to run setup)
Fatal error, no tech support email configured in this setup
The setup program seems to have failed on x86_64/glibc-2.1

Fatal error, no tech support email configured in this setup
The program returned an error code (1)

It is complaining about my system being installed on a 64 bit version of linux, and giving me another error about glibc-2.1. So in order to get past this there are two more steps. First enter a new export to take care of the glibc2.1 problem.

export SETUP_LIBC=glibc-2.1

Then to get past the error about being on 64bit, run your installer command like so.

linux32 ./linux_installer.sh

This should bring up the installer window for UT2003, and then all you have to do is follow the steps throughout the installation process.

Also note that if you close your terminal, you will have to do your two exports again before running the installer again.

If you have any questions or issues, please let me know!

Thank you!

-Orkultus-

PS. Big thanks to Skully on steam for helping me figure this out as well!

EDIT:  Ok i was having problems with the installer being able to read the cd’s when it asked me to swap them out. So what i did was took every file from the cdrom disks and copied them into a folder on my desktop called “ut2003”, and ran the installer from in there.

In order for the installer to read all the disks from within that folder i had to do

export SETUP_CDROM=/home/chuck/Desktop/ut2003” <— Just replace the SETUP_CDROM= location to where your ut2003 files are in the folder you just created. It should work with no problems after that.

EDIT AGAIN: For a issue about not having sound for 64bit systems…. you must copy /usr/lib32/libopenal.so to the system folder of the installed game, and rename it to openal.so. Or make a simlink

Example of where mine is installed:

ln -s /usr/lib32/libopenal.so.0 /usr/local/games/ut2003/System/openal.so

What i have been up to (Non Linux Related)

Well, i haven’t had much time lately to do any Linux Fix it posts, due to working a ton at my night job. I work at Home Depot, on the freight crew, and since it’s starting to get nicer outside, it has been really busy. Freight has been coming in 2 or 3 trucks at a time. I almost feel like i live there, more than i do at home.

In other news, i went in today to try and see what i could do about trading in my 2012 Kawasaki Ninja 250r for a 2012 Kawasaki Ninja 650r. They gave me a quote on what they would give me for the trade in, and said they would try to send me home on a 650, without having any down payment. I waited an hour in the building walking around while they talked to the bank. They said they would approve my loan, and give me a 7.59% APR, compared to my current, which is at a horrible 23%, and my monthly payments would be $170 dollars, instead of my current $200 dollars a month. I got really excited, and thought hell yeah!, i get to ride home a 650. Then he said, “but the bank would like to see $1880 dollars for a down payment”. Then all that happy feeling went away.  I didn’t have $1880, nor could i save up that much. I make just enough to pay bills; That’s it. So it looks like i wont  be getting my 650r.

Anyway, i hope other people are having much better luck than i am.

-Orkultus-