Frequent Wireless Connection Drops with the Atheros AR9462?

I know i had problems with it cutting out ALOT. all i did was disabled ipv6.

pretty easy to do.

1.) click on your wifi icon on the bottom panel, then go to “Network Settings”.

2.) click on the tab that says “wireless” on the left side.

3.) click on the “options…” button in the bottom right corner of the window.

4.) go to the tab that says “IPv6 Settings”

5.) Finally, click on the drop down bar where it says “Method:” and choose Ignore.

then press Save on the bottom of the window, and your good to go.

Ive noticed that i haven’t had any problems since.

-Orkultus-

About these ads

21 comments on “Frequent Wireless Connection Drops with the Atheros AR9462?

  1. cpbotha says:

    Is this fix still working for you?

    I am currently evaluating the Acer V3 571G with Full HD IPS screen for purchase, and I run exclusively Linux on everything. As far as I can see, the 571G has the Qualcomm Atheros AR5BWB222 alias AR9462 wifi chip too. I am curious as to whether the wifi is going to be stable.

    One more question: Could you check if your BIOS supports setting a master and user hard drive password?

  2. orkultus says:

    Ok since the day i had disabled iPv6, i have had no problems what so ever. Always have a good strong single, and no drops. If it does ever get quirky, it’s always been something up with my router.

    As for the passwords in BIOS. Here is what options it gives me.(Exactly as Shown)

    HDD0 Password Frozen
    Set Supervisor Password
    Set User Password
    Set HDD0 Password <— This one is Greyed Out

    Password on Boot

    I tried to see if i could add a password to the HDD0, but i couldn't select it at all. It just says Frozen. I will do some further investigating.

    Hope this helps you out.

    -Orkultus-

  3. orkultus says:

    Ok so i found you a solution to the HDD0 password. What you have to do is uplug the laptop, and remove the battery. I was told to Hold the power button down for a few seconds..but im not sure if it’s necessary. I would wait for 30 seconds anyway with it all unplugged. Put your battery in and plug in the charger.

    Ok so now turn the laptop back on but dont let it boot. The second you see “Press F2 for Bios”
    Press it.

    When you go over to the Security Tab in BIOS, you will see that HDD0 Password will now say “Clear”

    And the Set HDD0 Password will no loger be greyed out and you will be able to add a password.

    Then you can restart your computer after setting the password. If you start the computer after unplugging it and you let it boot, it will put the HDD0 back into Frozen Mode, and you will have to unplug it and pull the battery again.

    I tested it out, and it worked for me.

    Hope this helps

    -Orkultus-

    • cpbotha says:

      Thank you very much for your efforts, this helps me a great deal!

      It sounds like Acer implemented only part of the specification. In the full ATA security spec, there are two HDD passwords, the master and the user. If you forget the user, you can still use the master to unlock. If you forget both, you have to get a new hard drive.

      On the Acers, it seems you can unlock using a specially generated backdoor password, even if you forget your HDD password, see this for example: http://pcmediks.blogspot.nl/2010/11/how-to-remove-hdd-user-password-in-acer.html

      I’ve also contacted Acer support to ask for more detail. I need the full ATA security implementation, i.e. master and user, and NO backdoors possible. :)

      Thanks again very much for your help!

  4. orkultus says:

    Im glad i provided you with helpful information! I wish you luck

    -Orkultus-

  5. Mai says:

    Is Qualcomm atheros ar5bwb222 same as your router? I tried your solution and it didn’t work for me. I’m using Ubuntu 12.10… Any help/advice you can give me? My laptop is an acer aspire v5 with windows 8. We have fully installed Ubuntu on a 64gb USB flash drive.

  6. Sergei Winitzki says:

    One solution with Acer V3 571G (card AR9462) is to configure the ath9k module with options: nohwcrypt=1

    sudo nano /etc/modprobe.d/ath9k.conf

    the file should contain this:

    options ath9k nohwcrypt=1 blink=1 btcoex_enable=1 enable_diversity=1

    After saving this modified file, do

    rmmod ath9k modprobe -b ath9k

  7. Ken says:

    Sergei Winitzki’s solution worked perfectly for me. I’m also running the V3 571G Acer but my system did not the options line in the conf file at all. I actually don’t believe I had the conf file in the first place! I have not found it necessary to change ipv6 behaviour either. The only thing that did not work is his last line (rmmod ath9k modprobe -b ath9k). That gives me “rmmod: invalid option — ‘b'”. I have no idea what that line is supposed to do but my problem is solved anyway.

    Thank you very much. Greatly appreciated.

  8. kfm says:

    Disabling IPv6 solved the problem on my Acer Aspire S5 running Ubuntu 13.04. Thanks a lot!

  9. Jeremy says:

    Hi

    There is an improvement, but i still disconnect (but less frequently, and I connect faster)
    connection speed is correct

    MB :
    Asus Z87-PRO, the “Wifi GO!” is actually an Atheros AR9462, says lspci

    System :
    Ubuntu 13.04 : works out of the box
    Debian 7.1 : installed nearly every wifi firmware in hope to fix the problem (but could installing both free and non-free package lead to bugs ? … )

    anyway, thanks ! ;)

  10. Jeremy says:

    I already had router problems, but since then I set a fixed channel for the router, and it works on ubuntu

    i now tried the nohwcrypt=1 trick with

    echo “options ath9k nohwcrypt=1″ | sudo tee -a /etc/modprobe.d/ath9k.conf

    even if the file didn’t exist before

    I will tell you if it works

    Bye

    • Jeremy says:

      It seems that the latter method solved my problem

      I also reenabled ipv6 and it still works

      I also found out that ath9k should work with the free drivers

      I think it also depends of which network you are connected to, if it uses certificates or no, which encryption it uses, which wifi norm …

      I tested it on my home network, securised with WPA2, no certificates required, uses 802.11a or g

      thanks for your help ;)

  11. Trevor Helms says:

    Sergei Winitzki’s solution worked perfectly for me. I recently purchased an Acer Aspire S7-391 that has the Atheros AR9462. With Ubuntu 13.10, the internet was extremely slow for me when it did work, but often dropped connection. The file didn’t exist before I created it, either. Thanks, I thought my $1100 might have gone to waste until I found this!

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s